Ticket #767 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

GNU info handling is broken

Reported by: ingmar Owned by:
Priority: Sometime Milestone:
Component: misc Version: scm
Keywords: Cc:
Blocked By: Blocking:
Distribution: Exherbo

Description

Even though I have INFOPATH="/usr/share/info" in my environment, INFOPATH ends up empty when the gnu_info_index.bash hook is run. This causes /usr/share/info/dir not to be regenerated properly: it only contains refereneces to the package that last installed a .info file.

Confirmed on #exherbo by pipping, others claim that it works for them though.

Change History

comment:1 Changed 10 years ago by ingmar

Bo finally worked out why this fails.

% sudo printenv INFOPATH
%

I thought we sourced /etc/profile.env, but it turns out we only source it for ebuild.bash (pretend|bad_options|variable) cases.

We probably should source /etc/profile.env for hooks too? Just hooks or ...?

comment:2 Changed 10 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to fixed

4278544

Note: See TracTickets for help on using tickets.