Ticket #756 (closed ebuild-defect: upstream)

Opened 11 years ago

Last modified 11 years ago

paludis 0.36.0/1 hangs after postinst on gdm

Reported by: uzytkownik Owned by:
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.36.1
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

paludis 0.36.0/1 hangs after postinst on gdm. It displays the postinst message and do not do anything else (i.e. it does not occupy CPU, it just not work. It can be killed).

Change History

comment:1 Changed 11 years ago by ciaranm

Can you find out what it's doing using gdb please?

comment:2 Changed 11 years ago by uzytkownik

Problem vanished after deleting /var/gdm/.gdmfifo. However - interesting thing is that according to lsof nothing was holding the fd to this file. I'll post however when the file will be recreated (after gdm restart)?

comment:3 Changed 11 years ago by ciaranm

  • Status changed from new to closed
  • Type changed from defect to ebuild-defect
  • Resolution set to upstream

So it's something the ebuild is doing, not something Paludis is doing. Not much we can do about that I'm afraid.

comment:4 Changed 11 years ago by uzytkownik

Hmm. Emerge works with it (checked the first time I encountered it)...

comment:5 Changed 11 years ago by ciaranm

Are you saying it reproducibly works with Portage, and reproducibly fails with Paludis?

comment:6 Changed 11 years ago by uzytkownik

As far as paludis is concerned: I reproduced it several times (this time I started invastigation and this is the reason of deleting file) updating from various versions of gdm (i.e. at least once or twice with some time betwean) As far as portage is concerned: I check it once just after the first or second encounter. However I'd guess that many other would find out the problem.

Update: I asked on #gentoo-desktop and at least in one case this file is opened by gdm.

comment:7 follow-up: ↓ 8 Changed 11 years ago by ciaranm

Have you established for definite that this isn't an intermittent problem that just happened to work when you used Portage?

comment:8 in reply to: ↑ 7 Changed 11 years ago by uzytkownik

Replying to ciaranm:

Have you established for definite that this isn't an intermittent problem that just happened to work when you used Portage?

Sorry - I don't understend the question.

comment:9 Changed 11 years ago by ciaranm

It's not Paludis hanging, it's something the ebuild itself does that's the problem. What's most likely is that the ebuild does something that sometimes works and sometimes doesn't, and that the one time you tried it with Portage happened to be one of those times it worked.

There are other explanations, but this one is most likely, so we need to rule it out first.

Note: See TracTickets for help on using tickets.