Ticket #744 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

resume command problem with ::accounts

Reported by: kimrhh Owned by:
Priority: Sometime Milestone:
Component: clients/paludis Version: scm
Keywords: Cc:
Blocked By: Blocking: 731
Distribution: Exherbo

Description

The resume command refers to the package that had already been installed, but it disappeared because existing accounts don't show up in ::accounts anymore.

result:

kimrhh@kimrhh-desktop ~ $ paludis --log-level qa --install --add-to-world-spec 'x11-drivers/xf86-video-nouveau' --serialised 0.25 'package;=x11-proto/randrproto-1.3.0:0::x11;installed;has_all_deps;S' 'package;=x11-proto/xextproto-7.0.5:0::x11;installed;has_all_deps;S' 'package;=x11-proto/xproto-7.0.15:0::x11;installed;has_all_deps;S' 'package;=x11-libs/libX11-1.2:0::x11;installed;has_all_deps;S' 'package;=x11-libs/libXext-1.0.5:0::x11;installed;has_all_deps;S' 'package;=x11-libs/libXi-1.2.1:0::x11;installed;has_all_deps;S' 'package;=x11-dri/mesa-7.3:0::x11;installed;has_all_deps;S' 'package;=media-libs/freetype-2.3.9:2::x11;installed;has_all_deps;S' 'package;=x11-libs/pixman-0.14.0:1::x11;installed;has_all_deps;S' 'package;=sys-apps/dbus-1.2.12-r1:0::arbor;installed;has_all_deps;S' 'package;=dev-libs/glib-2.18.4:2::arbor;installed;has_all_deps;S' 'package;=dev-libs/dbus-glib-0.80:1::arbor;installed;has_all_deps;S' 'package;=group/policykit-0::accounts;installed-accounts;has_all_deps;S' 'package;=user/policykit-0::accounts;installed-accounts;has_all_deps;S' 'package;=sys-auth/PolicyKit-0.9:0::compnerd;installed;has_all_deps;S' 'package;=sys-auth/ConsoleKit-0.3.0:0::compnerd;installed;has_all_deps;S' 'package;=x11-apps/xkeyboard-config-1.5:0::x11;installed;has_all_deps;S' 'package;=x11-server/xorg-server-1.6.0:0::x11;installed;has_all_deps;S' 'package;=x11-drivers/xf86-video-vesa-2.2.0:0::x11;installed;has_all_deps;S' 'package;=sys-apps/coreutils-7.1-r1:0::arbor;installed;has_all_deps;S' 'package;=net-misc/curl-7.19.4:0::arbor;installed;has_all_deps;P' 'package;=dev-scm/git-1.6.2.1:0::arbor;installed;has_all_deps;P' 'package;=x11-drivers/xf86-video-nouveau-scm:0::x11;installed;has_all_deps;P'

Building target list... Unhandled exception:

  • In program paludis --log-level qa --install --add-to-world-spec x11-drivers/xf86-video-nouveau --serialised 0.25 package;=x11-proto/randrproto-1.3.0:0::x11;installed;has_all_deps;S package;=x11-proto/xextproto-7.0.5:0::x11;installed;has_all_deps;S package;=x11-proto/xproto-7.0.15:0::x11;installed;has_all_deps;S package;=x11-libs/libX11-1.2:0::x11;installed;has_all_deps;S package;=x11-libs/libXext-1.0.5:0::x11;installed;has_all_deps;S package;=x11-libs/libXi-1.2.1:0::x11;installed;has_all_deps;S package;=x11-dri/mesa-7.3:0::x11;installed;has_all_deps;S package;=media-libs/freetype-2.3.9:2::x11;installed;has_all_deps;S package;=x11-libs/pixman-0.14.0:1::x11;installed;has_all_deps;S package;=sys-apps/dbus-1.2.12-r1:0::arbor;installed;has_all_deps;S package;=dev-libs/glib-2.18.4:2::arbor;installed;has_all_deps;S package;=dev-libs/dbus-glib-0.80:1::arbor;installed;has_all_deps;S package;=group/policykit-0::accounts;installed-accounts;has_all_deps;S package;=user/policykit-0::accounts;installed-accounts;has_all_deps;S package;=sys-auth/PolicyKit-0.9:0::compnerd;installed;has_all_deps;S package;=sys-auth/ConsoleKit-0.3.0:0::compnerd;installed;has_all_deps;S package;=x11-apps/xkeyboard-config-1.5:0::x11;installed;has_all_deps;S package;=x11-server/xorg-server-1.6.0:0::x11;installed;has_all_deps;S package;=x11-drivers/xf86-video-vesa-2.2.0:0::x11;installed;has_all_deps;S package;=sys-apps/coreutils-7.1-r1:0::arbor;installed;has_all_deps;S package;=net-misc/curl-7.19.4:0::arbor;installed;has_all_deps;P package;=dev-scm/git-1.6.2.1:0::arbor;installed;has_all_deps;P package;=x11-drivers/xf86-video-nouveau-scm:0::x11;installed;has_all_deps;P:
  • When performing install action from command line:
  • When adding serialised entry 'package;=group/policykit-0::accounts;installed-accounts;has_all_deps;S':
  • When finding the single version from packages matching =group/policykit-0::accounts with filter all matches:
  • Did not get unique result for 'the single version from packages matching =group/policykit-0::accounts with filter all matches' (got { }) (paludis::DidNotGetExactlyOneError?)

Change History

comment:1 Changed 11 years ago by ciaranm

  • Blocking set to 731

comment:2 Changed 11 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to fixed

61abcbc either fixes this or breaks your system

Note: See TracTickets for help on using tickets.