Ticket #742 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

Strange warnings - dependency resolving

Reported by: vcunat Owned by:
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.36.0
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

When installing I often see really strange warnings in the form like:

... No visible packages matching 'virtual/xft', falling back to installed package 'virtual/xft-7.0::installed'

or

... No visible packages matching '>=sys-devel/binutils-config-1.8-r6', falling back to installed package 'sys-devel/binutils-config-1.9-r4::installed'

The strange thing is, that the "fall-back" version actually fits the unmatched dep.spec.

Attachments

info.txt Download (28.9 KB) - added by vcunat 11 years ago.
paludis --info xft binutils

Change History

comment:1 Changed 11 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to invalid

This means you don't have any installable packages matching the spec in question. If the fallback version didn't match the spec, it'd be an error.

The virtual/xft one is because it's been removed. Uninstall it and reinstall anything that used to depend upon it.

Changed 11 years ago by vcunat

paludis --info xft binutils

comment:2 Changed 11 years ago by vcunat

I understand now, thanks for a really quick reply.

Note: See TracTickets for help on using tickets.