Ticket #703 (closed defect: wontfix)

Opened 11 years ago

Last modified 11 years ago

portage2paludis uncomments commented line when creating bashrc

Reported by: Unaimed Owned by: pioto
Priority: Sometime Milestone:
Component: portage2paludis Version: 0.34.0_alpha2
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

When i used the portage2paludis i got an unexpected behaviour when it uncommented my ldflags from make.conf and put them in bashrc. I do not know if this only affects bashrc or other configuration files aswell.

I used the latest (as of now) copy of  http://git.pioto.org/?p=paludis-scripts.git;a=blob_plain;f=portage2paludis.bash.

I will attach make.conf and bashrc.

Attachments

make.conf Download (925 bytes) - added by Unaimed 11 years ago.
bashrc Download (169 bytes) - added by Unaimed 11 years ago.
attached the wrong bashrc

Change History

Changed 11 years ago by Unaimed

Changed 11 years ago by Unaimed

attached the wrong bashrc

comment:1 Changed 11 years ago by zlin

Your analysis of the problem is wrong. The script uses portageq envvar LDFLAGS to query the existing LDFLAGS from portage. portageq sources the make.defaults files from your selected profile. One of these happens to set the LDFLAGS="-Wl,-O1" because Gentoo developers are stupid. Whether or not putting this in your paludis bashrc is desirable is debatable but nothing is getting uncommented.

comment:2 Changed 11 years ago by Unaimed

Okay, thanks for the explanation.

Feel free to close the bug from my side.

comment:3 Changed 11 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.