Ticket #1327 (closed defect: upstream)

Opened 5 years ago

Last modified 5 years ago

change to --new-compress in dorsync causes errors syncing gentoo tree

Reported by: hlandgar Owned by:
Priority: Sometime Milestone:
Component: clients/cave Version: 2.4.0
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

Using the lasted paludis syncing of gentoo tree fails with:

rsync: on remote machine: --new-compress: unknown option

Seems the rsync servers are not on 3.1 yet.

I have not found a way to override the --new-compress rsync option in the gentoo repository file.

Change History

comment:1 Changed 5 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to upstream

Most Gentoo mirrors should be running 3.1. You can manually specify one that is, if you have trouble, and complain to the owners of any that aren't.

Unfortunately there's no good way of handling this: newer versions of rsync don't support the old compress.

comment:2 Changed 5 years ago by hlandgar

I have tried 5 or 6 mirrors manually and also tried auto selection. None were running 3.1 and all failed.

I have changed line 92 in dorsync to --compress and that works around the problem. I would suggest you give users a way to pick the option they want in the repository file or better yet handle the error and try again with the option that works.

3.0.9 is still stable in gentoo and until 3.1 series is stablized I assume problems will persist.

Note: See TracTickets for help on using tickets.