Ticket #1166 (closed defect: upstream)

Opened 9 years ago

Last modified 9 years ago

Warning when parsing gentoo news

Reported by: Lustmored Owned by:
Priority: Sometime Milestone:
Component: clients/cave Version: 0.60.4
Keywords: Cc:
Blocked By: Blocking:
Distribution: N/A

Description

cave@1306157943: [WARNING e.package_dep_spec.use_not_allowed] In thread ID '5191':

... In program cave --log-level warning execute-resolution --set --continue-on-failure if-satisfied --world-specs world world: ... When executing chosen resolution: ... When triggering hook 'install_all_post': ... When performing hook 'install_all_post' for repository 'gentoo': ... When updating news at location '/usr/portage/metadata/news' for repository 'gentoo': ... When handling news entry '/usr/portage/metadata/news/2011-05-22-kdeprefix': ... When checking Display-If-Installed headers: ... When parsing elike package dep spec 'kde-base/kdelibs[kdeprefix]': ... When parsing generic package dep spec 'kde-base/kdelibs[kdeprefix]': ... USE dependencies not safe for use here

And it will probably pop up every time it will parse news, which is quite annoying.

Change History

comment:1 Changed 9 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to upstream

The warning is correct. Use dependencies aren't allowed there. You should file a bug upstream a) asking them to remove the use dep, and b) asking them to come up with a proper solution to EAPIs and news files.

Note: See TracTickets for help on using tickets.