Ticket #1165 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

Improve cave resolve "Unsuitable canditates:" output.

Reported by: sera Owned by:
Priority: Sometime Milestone:
Component: clients/cave Version: 0.60.4
Keywords: Cc:
Blocked By: Blocking:
Distribution: N/A

Description

See attachment for output of all commands.

Excerpt actual output of cave resolve:

!   dev-java/netbeans-harness
    Reasons: dev-util/netbeans
    Unsuitable candidates:
      * dev-java/netbeans-harness-9999_p20110508:9999::layman (in ::fordfrog)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet ~dev-java/netbeans-harness-7.0, use existing if possible, installing to / from dev-util/netbeans
      * dev-java/netbeans-harness-9999_p20110512:9999::layman (in ::fordfrog)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet ~dev-java/netbeans-harness-7.0, use existing if possible, installing to / from dev-util/netbeans

Suggesting dev-java/netbeans-harness-7.0:7.0::gentoo seems to be the only reasonable choice here even so it's keyword masked. cave resolve lists the others.

Change History

comment:1 Changed 9 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to duplicate

See ticket:1057. But note that cave only shows that output at all when the right answer isn't obvious.

Note: See TracTickets for help on using tickets.