Ticket #1047 (closed defect: wontfix)

Opened 10 years ago

Last modified 10 years ago

With USE pbins you need libarchive build without the xattr USE flag - use dependency should be used

Reported by: uzytkownik Owned by:
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.54.9
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

As most package managers for portage use EAPI>=2 libarchive dependency should be specified by USE dependnecy.

Change History

comment:1 Changed 10 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to wontfix

The paludis overlay ebuilds use paludis-1, which is horrible, but we're not changing it until there's an EAPI that supports all the functionality we need to do things properly.

The Gentoo tree ebuilds use EAPI 0 on purpose. We're not changing those until Gentoo starts shipping stages that include support for an EAPI that has support for everything we want. There's no point in going through the whole mess of using a newer EAPI and making sure we keep old versions around when we'll have to do it all over again later on.

Note: See TracTickets for help on using tickets.