Ticket #990 (closed enhancement: wontfix)

Opened 9 years ago

Last modified 9 years ago

Conditional unmasking (unmask SVC version untill x.y.z release)

Reported by: uzytkownik Owned by:
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.54.3
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

I often use SVC version when it contains bug fix and/or feature I need which will appear for some x.y.z release. For obvious reasons I'd prefere keep my system as stable as possible and therefore use SVC version only if there is no x.y.z (or newer) installable.

I'm not quite sure how should syntax look like but possibility of such unmasking would greatly improve paludis (i.e. unmask version x if version y or newer is not in portage).

Change History

comment:1 Changed 9 years ago by ciaranm

Hrm. The problem is, this leads to "unmask X only if Y is not unmasked", which in turn lets you set up contradictory unmasking rules...

comment:2 Changed 9 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to wontfix

There's no way of doing this consistently.

Note: See TracTickets for help on using tickets.