Ticket #949 (reopened defect)

Opened 7 years ago

Last modified 7 years ago

paludis --query versions line doesn't show keyword info correctly

Reported by: njw Owned by:
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.50.0
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

In my /etc/paludis/keywords I accept x86 keywords, but not amd64.

I therefore would expect the versions line to mark with (~) any versions which aren't marked x86. However it appears to mark (~) as though amd64 was accepted.

For example, milkytracker is currently KEYWORDS="amd64 ~x86", but paludis --query milkytracker returns:

  • media-sound/milkytracker

gentoo: 0.90.80

Whereas I'd expect it to return:

  • media-sound/milkytracker

gentoo: 0.90.80(~)

Change History

comment:1 Changed 7 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to wontfix

amd64 ~x86 doesn't make sense. Accepting ~x86 doesn't imply accepting x86, so if you really want to mix arch keywords, you should do amd64 x86 ~x86.

comment:2 Changed 7 years ago by njw

  • Status changed from closed to reopened
  • Resolution wontfix deleted

Sorry Ciaran, I think I wasn't clear.

I meant the milkytracker ebuild is amd ~x86. I only accept x86. So I should see 0.90.80(~) in the query output.

comment:3 Changed 7 years ago by ciaranm

Ah, I see. The way it works now is that (~) shows up if a package isn't keyword masked, and if none of the package's keywords are stable. I think what you're expecting is that the (~) should show up if a package isn't keyword masked, and if none of the *accepted* keywords are stable.

The problem is, we don't support the notion of whether or not individual keywords are accepted. From an API perspective, it's possible for environments to accept only, say, packages that have both the 'x86' and the 'security' keywords, but not packages that only have one of those.

comment:4 Changed 7 years ago by njw

OK, I understand. Thanks a lot for taking the time to explain this.

Note: See TracTickets for help on using tickets.