Ticket #822 (closed enhancement: wontfix)

Opened 4 years ago

Last modified 4 years ago

Ignore blocking if blocking package is removed during operation

Reported by: uzytkownik Owned by:
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.44.1
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

Sometimes packages are very tightly interconnected and they block other versions lower then themselves - like qt.

The problem is the updates of them. Portage seems to notice that others are being upgraded and it does not says a word. However paludis does not allow installations and it requires manual uninstallation and then installation.

* x11-libs/qt-test::installed :4 [! 4.6.1 blocking]
    Reasons: x11-libs/qt-core-4.6.2:4::gentoo, x11-libs/qt-dbus-4.6.2:4::gentoo, 7 more
* x11-libs/qt-svg::installed :4 [! 4.6.1 blocking]
    Reasons: x11-libs/qt-core-4.6.2:4::gentoo, x11-libs/qt-dbus-4.6.2:4::gentoo, 5 more
* x11-libs/qt-sql::installed :4 [! 4.6.1 blocking]
    Reasons: x11-libs/qt-core-4.6.2:4::gentoo, x11-libs/qt-dbus-4.6.2:4::gentoo, 3 more
* x11-libs/qt-script::installed :4 [! 4.6.1 blocking]
    Reasons: x11-libs/qt-core-4.6.2:4::gentoo, x11-libs/qt-script-4.6.2:4::gentoo
* x11-libs/qt-qt3support::installed :4 [! 4.6.1 blocking]
    Reasons: x11-libs/qt-core-4.6.2:4::gentoo, x11-libs/qt-dbus-4.6.2:4::gentoo, 3 more
* x11-libs/qt-opengl::installed :4 [! 4.6.1 blocking]
    Reasons: x11-libs/qt-core-4.6.2:4::gentoo, x11-libs/qt-dbus-4.6.2:4::gentoo, 6 more
* x11-libs/qt-gui::installed :4 [! 4.6.1 blocking]
    Reasons: x11-libs/qt-core-4.6.2:4::gentoo, x11-libs/qt-gui-4.6.2:4::gentoo
* x11-libs/qt-dbus::installed :4 [! 4.6.1 blocking]
    Reasons: x11-libs/qt-core-4.6.2:4::gentoo, x11-libs/qt-dbus-4.6.2:4::gentoo, 1 more
* x11-libs/qt-core::installed :4 [! 4.6.1 blocking]
    Reasons: x11-libs/qt-core-4.6.2:4::gentoo
(...)
* x11-libs/qt-core :4 [U 4.6.1 -> 4.6.2]
    (-aqua) -debug doc glib iconv -optimized-qmake pch qt3support ssl build_options: -optional_tests split strip -trace -preserve_work
    153.16 MBytes to download
* x11-libs/qt-script :4 [U 4.6.1 -> 4.6.2]
    (-aqua) -debug iconv pch build_options: -optional_tests split strip -trace -preserve_work
* x11-libs/qt-dbus :4 [U 4.6.1 -> 4.6.2]
    (-aqua) -debug pch build_options: -optional_tests split strip -trace -preserve_work
* x11-libs/qt-gui :4 [U 4.6.1 -> 4.6.2]
    accessibility (-aqua) cups dbus -debug glib gtk mng -nas -nis pch qt3support -raster tiff -xinerama build_options: -optional_tests split strip -trace -preserve_work
* x11-libs/qt-sql :4 [U 4.6.1 -> 4.6.2]
    (-aqua) -debug (-firebird) iconv -mysql -odbc pch -postgres qt3support sqlite build_options: -optional_tests split strip -trace -preserve_work
* x11-libs/qt-qt3support :4 [U 4.6.1 -> 4.6.2]
    accessibility (-aqua) -debug -kde pch -phonon build_options: -optional_tests split strip -trace -preserve_work
* x11-libs/qt-svg :4 [U 4.6.1 -> 4.6.2]
    (-aqua) -debug iconv pch build_options: -optional_tests split strip -trace -preserve_work
* x11-libs/qt-opengl :4 [U 4.6.1 -> 4.6.2]
    (-aqua) -debug pch qt3support build_options: -optional_tests split strip -trace -preserve_work
* x11-libs/qt-test :4 [U 4.6.1 -> 4.6.2]
    (-aqua) -deb
(...)
* Cannot continue with install due to the errors indicated above

Change History

comment:1 Changed 4 years ago by uzytkownik

  • Type changed from defect to enhancement

comment:2 Changed 4 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to wontfix

We're never going to do it the way Portage does it, since the way Portage does it is extremely dangerous and often leads to silently broken systems.

The new resolver has a cleaner, safer way of handling it, but that's not going to be introduced until I'm absolutely sure that it will never do something stupid.

Note: See TracTickets for help on using tickets.