Ticket #694 (closed defect: invalid)

Opened 9 years ago

Last modified 9 years ago

Security set does not work

Reported by: MageSlayer Owned by:
Priority: MinorRelease Milestone:
Component: clients/paludis Version: 0.32.4
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

Security package set does not work in 0.32.4. It says glsa is not enabled at compile time, but glsa use flags have disappeared since paludis-0.32.1. See log below.

dencomp denis # paludis --version paludis 0.32.4

Paludis comes with ABSOLUTELY NO WARRANTY. Paludis is free software, and you are welcome to redistribute it under the terms of the GNU General Public License, version 2.

dencomp denis # paludis -pi security paludis@1230913287: [WARNING repository.blacklisted] Repository 'paludis-extras' is blacklisted with reason 'Repeatedly broken, full of highly buggy code and all round harmful. Do not use.'. Building target list... Unhandled exception:

  • In program paludis (--show-use-descriptions none --dl-upgrade as-needed) -pi security:
  • When performing install action from command line:
  • When adding install target 'security':
  • When parsing user package dep spec 'security':
  • When parsing generic package dep spec 'security':
  • When building security or insecurity package set:
  • When parsing security advisory '/usr/portage/metadata/glsa/glsa-200310-03.xml':
  • Error: Not available: Cannot create GLSA from XML file '/usr/portage/metadata/glsa/glsa-200310-03.xml' because GLSA support was not enabled at compile time (paludis::NotAvailableError?)

Change History

comment:1 Changed 9 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to invalid

--enable-xml

Note: See TracTickets for help on using tickets.