Ticket #689 (closed defect: invalid)

Opened 9 years ago

Last modified 9 years ago

Unable to umnask dev-libs/boost-1.37.0 and dev-utils/boost-build-1.37.0

Reported by: zaufi Owned by:
Priority: MajorRelease Milestone:
Component: clients/paludis Version: 0.30.3
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

$subj.

I've tryed the following lines in /etc/paludis/package_unmask.conf:

=dev-libs/boost-1.37.0 =dev-utils/boost-build-1.37.0

and when I try to paludis --install --dl-reinstall if-use-changed -p everything I've got the following errors:

paludis@1229606076: [WARNING repository.blacklisted] Repository 'paludis-extras' is blacklisted with reason 'Repeatedly broken, full of highly buggy code and all round harmful. Do not use.'. Building target list...

  • I can't find usr/bin/update-eix-functions.sh, aborting

Building dependency list...paludis@1229606078: [WARNING dep_list.ignoring_dependencies] In program paludis (--log-level warning --dl-reinstall-scm weekly --show-package-descriptions all) --install --dl-reinstall if-use-changed -p everything:

... When performing install action from command line: ... When executing install task: ... When building dependency list: ... When adding NamedSetDepSpec? 'everything': ... When adding PackageDepSpec? 'app-admin/eselect-paludis-hooks': ... When adding installed package 'app-admin/eselect-paludis-hooks-0.3.0:0::installed': ... When adding run dependencies as post dependencies: ... When adding PackageDepSpec? 'sys-apps/paludis': ... When adding installed package 'sys-apps/paludis-0.32.3:0::installed': ... Ignoring run dependencies due to exception 'Error searching for 'dev-util/boost-build:1.37': no available versions' (paludis::AllMaskedError?)

Query error:

  • In program paludis (--log-level warning --dl-reinstall-scm weekly --show-package-descriptions all) --install --dl-reinstall if-use-changed -p everything:
  • When performing install action from command line:
  • When executing install task:
  • When building dependency list:
  • When adding NamedSetDepSpec? 'everything':
  • When adding PackageDepSpec? 'dev-libs/boost':
  • When adding package 'dev-libs/boost-1.37.0:1.37::gentoo':
  • When adding build dependencies as pre dependencies:
  • When adding PackageDepSpec? 'dev-util/boost-build:1.37':
  • All versions of 'dev-util/boost-build:1.37' are masked. Candidates are:
    • dev-util/boost-build-1.37.0:1.37::gentoo: Masked by repository (/usr/portage/profiles/package.mask: Tiziano Müller <dev-zero@…> (16 Dec 2008) Mask for testing)

paludis@1229606086: [WARNING repository.blacklisted] Repository 'paludis-extras' is blacklisted with reason 'Repeatedly broken, full of highly buggy code and all round harmful. Do not use.'.

  • No unread news items found

Change History

comment:1 in reply to: ↑ description Changed 9 years ago by filko_

Replying to zaufi:

$subj.

I've tryed the following lines in /etc/paludis/package_unmask.conf:

=dev-libs/boost-1.37.0 =dev-utils/boost-build-1.37.0

It's dev-util.

comment:2 Changed 9 years ago by ingmar

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.