Ticket #684 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

superfluous video card use flags with xorg-server

Reported by: hrz Owned by:
Priority: Sometime Milestone:
Component: environments/portage Version: 0.32.2
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

As per  http://trac.pioto.org/paludis/ticket/201#comment:3 I'm opening a new bug.

I'm testing Paludis whilst still using the Portage environment and ran across a problem whereby running

paludis --environment portage --install --dl-reinstall if-use-changed --pretend x11-base/xorg-server

caused many unwanted x11-drivers/xf86-* packages to be pulled in. Originally I had

VIDEO_CARDS="radeon"

in /etc/make.conf but after reading bug #201 set it to

VIDEO_CARDS="-* radeon"

only to end up with the following error:

Unhandled exception:

  • In program paludis --environment portage --install --dl-reinstall if-use-changed --pretend x11-base/xorg-server:
  • When performing install action from command line:
  • When executing install task:
  • When building dependency list:
  • When adding PackageDepSpec? 'x11-base/xorg-server':
  • When adding package 'x11-base/xorg-server-1.3.0.0-r6:0::gentoo':
  • When showing suggestions in post dependencies key:
  • When making Choices key for 'x11-base/xorg-server-1.3.0.0-r6:0::gentoo':
  • When using raw_iuse_key and raw_use_key to populate choices:
  • When loading known use expand names for prefix 'video_cards:
  • Name '-*' is not a valid choice name with prefix (paludis::ChoiceNameWithPrefixError?)

In summary I can't seem to find any way of building xorg-server with only the driver specified in VIDEO_CARDS.

Attachments

make.conf Download (2.6 KB) - added by hrz 10 years ago.
/etc/make.conf
paludis.info Download (7.0 KB) - added by hrz 10 years ago.
paludis --info

Change History

comment:1 Changed 10 years ago by ciaranm

Please provide your make.conf and the output of paludis -q xorg-server::/?.

Changed 10 years ago by hrz

/etc/make.conf

comment:2 Changed 10 years ago by hrz

paludis -q xorg-server::/?

paludis@1228945470: [WARNING portage_environment.dodgy] Use of Portage configuration files will lead to sub-optimal performance and loss of functionality. Full support for Portage configuration formats is not guaranteed; issues should be reported via trac.
* x11-base/xorg-server::/?
    gentoo:                  1.3.0.0-r6* {:0} 
    Homepage:                http://xorg.freedesktop.org/
    Description:             X.Org X servers
    Herds:                   x11
    Use flags:               -3dfx -debug -dmx dri ipv6 -kdrive -minimal nptl sdl xorg -xprint input_devices: -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics evdev -fpit -hyperpen -jamstudio -joystick keyboard -magellan -microtouch mouse -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom video_cards: apm ark chips cirrus cyrix dummy -epson fbdev -fglrx glint i128 i740 (-impact) imstt intel mach64 mga neomagic (-newport) nsc nv -nvidia r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) tdfx tga trident tseng v4l vesa vga via vmware voodoo Build Options: -optional_tests split strip

comment:3 Changed 10 years ago by ciaranm

I can't reproduce this. For me VIDEO_CARDS="radeon" in make.conf gives me just radeon. This is also what I'd expect from the code. Are you sure you're running 0.32.2?

comment:4 Changed 10 years ago by ciaranm

Oh, yes, I can reproduce this so long as I don't have USE="-*" in there.

Changed 10 years ago by hrz

paludis --info

comment:5 Changed 10 years ago by ciaranm

I think 3679eab and cfcb7e0 fix this. Can someone confirm?

comment:6 Changed 10 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.