Ticket #582 (closed discussion: fixed)

Opened 10 years ago

Last modified 9 years ago

migration: woodhaven.pioto.org => everglades.pioto.org

Reported by: pioto Owned by: pioto
Priority: Sometime Milestone:
Component: infra Version:
Keywords: Cc: cJ-paludis@…
Blocked By: Blocking:
Distribution: N/A

Description (last modified by pioto) (diff)

I've opted for a new host - linode. This ticket is now for tracking all the necessary steps to migrate everything over there.

Once the server is mostly set up (necessary packages installed and basically configured), I'll make trac and svn read-only. Then I'll migrate all the data, test, and finally update dns.

Things to migrate:

First, I'll migrate things that aren't visible / write accessable to the rest of 'ya:

  • personal mail (most of what postfix does)
    • postfix
    • postgrey
    • spamassassin
    • procmail
    • saslauthd
    • courier-imapd
  • personal webpages
  • my blog
    • maybe move to the free blog from work...

Then, the things that paludis people use. First, all of these will need to be marked read-only (I'll try to advertise the migration at all these places as possible):

  • mailman
  • trac
  • subversion
    • svnserve
    • webdav
  • apache
    • vhosts
  • mysql
    • need to fix or drop the broken gallery db so i can do a mysqldump

Finally:

  • update dns
    • move all cnames that point at woodhaven to point at everglades

Change History

comment:1 Changed 10 years ago by pioto

  • Status changed from new to accepted

comment:2 Changed 9 years ago by vetienne

  • Distribution set to Gentoo

Maybe you could be interested with being hosted on one server of mine which has very few use, a good network connection ( 100mb symmetric ), located in a server farm ( so good hardware support, ... )

I could provide a ssh account or even root account, there's still some Gb free.

What would be your spec for the necessary hardware ? (have one server with only 256mo ram and celeron and one a little more powerfull with 1gb ram and intel core ). Depending on your need we could use one or the other. Maybe the second one will be a better choice ( i'm in a very slow migrating process from the first to the second one ). So for the moment it is only use as backup server for the company (rsync) and provide http for a very few and very few visited web site ( should be something as ridiculous as 100 pages/ day )

As for software i'm (naturally) on a hardened gentoo. Apache 2.2 is already installed, mysql, postfix, bind and openvpn also. TRAC not installed but why not.

I think i would prefer not to use xen but that you install your software on the bare system, if you don't mind.

The server is already paid for more than one year. So there's few risk of instability as far as you don't hurt my data. And it will cost you nothing. Maybe you will provided me with hints on how to install a secure server that 's all i will ask to you.

For time to time i update the software but not too often and will ask your confirmation before upgrading important one ( apache, mysql )

Server seems stable ( but as i'm not really using it that not certain ). Hardware certainly is ( no hardware problem during the last year )

Regards,

Vincent

comment:3 Changed 9 years ago by pioto

  • Distribution changed from Gentoo to N/A

The current server has 512M of ram, and that isn't enough... (at least w/o some swap space).

Personally, I haven't used hardened, but I think I've heard of various problems caused by it in the past. I would also much prefer to have root access to whatever server / virtual server (xen, etc), that I ultimately move things to, so that I can take care of things myself.

So... maybe? But we're still looking at a few other options as well.

comment:4 Changed 9 years ago by vetienne

ok so the 1Go server is the only option. it has something like 1G swap ( don't remember exactly either 512Mo or 1Go ). And you would get a root access to it ( via ssh key ), that's seems the only sane option. The kernel could be reinstalll if you think hardened could be a potential problem ( i have no strong feeling for it. For the moment no problem with it, but it was more a test to see what could be achieve ). You would have to take care of things, you could trust me on this ( maybe i would interfere a bit by adding a few sample html/php application and mysql base from time to time : that's how i show some of our development before putting it in another server for production but for the rest, most often i have no time to do it (web development is just a small part of our work :we're mainly in embedded dev ) so would be glad to give you the key to the server :))).

Drop me a note ( ve at vetienne dot net ) if your interested for an access - even if it's only for testing (or just to see the current state of desaster ...).

And yes it's normal/sane that you're looking at other options.The contrary will not be a good thing. As I'm using paludis at home ( and investigating in using it in our embedded system when the destination will be finished ), it's just a way for me to eventually be useful and give back something. But if you found something better, go for it no problem for me ( will found another opportunity later )

comment:5 Changed 9 years ago by pioto

I'm inclined to simply purchase more reliable hosting myself. To help to that end, we've added a few donation buttons on the website. The money will go towards offsetting the cost of better hosting. See  http://paludis.pioto.org/faq/general.html#contribute for more info.

comment:6 Changed 9 years ago by pioto

For reference, we currently have hosting with  VPS Link, at the Link-4 level.

comment:7 Changed 9 years ago by pioto

  • Type changed from task to discussion

At this point, I think our reasonable options are to either:

  1. Purchase a more expensive VPS server.
  2. Purchase either a managed dedicated or co-located server.

I'm looking into purchasing a more expensive, xen-driven (meaning I actually get swap space) server from  VR Hosting, but their sales department hasn't gotten back to me yet. I can also try to do the same with  VPS Link, as they've started to offer Xen recently (my current server is vserver based, and a royal pain).

If we go with the latter route, it will obviously cost more money, some of which I'm willing to pay, but some of which I would appreciate some help with. I would almost certainly choose to do this with my current employer,  pair Networks.

comment:8 Changed 9 years ago by Zougloub

  • Cc cJ-paludis@… added

I have a small  OVH kimsufi08 dedicated server and could provide free hosting, under the form of an account on the server (I can't give root access, but I am often on #Paludis and can do root stuff). 64bit, 1GB RAM, any swap you want, Gentoo with Paludis, any software you want. I don't know if the power or access level requirement are sufficient for your needs, but that's all I can do at the moment.

HTH,

comment:9 Changed 9 years ago by pioto

  • Description modified (diff)
  • Summary changed from woodhaven.pioto.org is sucking big time to migration: woodhaven.pioto.org => everglades.pioto.org

comment:10 Changed 9 years ago by gk

In case you are still interested, we (LP.PL) are willing to discuss hosting OpenVZ VPS for you. We are using Gentoo everywhere and will be happy to help. As to exact needs, conditions, specifications and (greatly reduced for you) prices please contact jj at lp.pl with CC to gk at lp.pl. Thanks!

comment:11 Changed 9 years ago by pioto

there may be a sight dns hickup while things shift over to a new dns server...

comment:12 Changed 9 years ago by pioto

okay, the new dns server is in place. my blog is migrated. i'm going to start configuring mail on the new server next, then copy all the mailman data over, and update dns

comment:13 Changed 9 years ago by pioto

Now svn and trac are on the new server (and dns has been updated). Now all that's really left is mail.

comment:14 Changed 9 years ago by pioto

SVN is now read only, waiting on ciaran to push stuff into git. Then, paludis' source code will live at:

git://git.pioto.org/paludis{,-overlay,-scratch}.git
git+ssh://git@git.pioto.org/paludis{,-overlay,-scratch}.git (for developers)
http://git.pioto.org/ (for gitweb)

comment:15 Changed 9 years ago by pioto

  • Status changed from accepted to closed
  • Resolution set to fixed

Mailman has been migrated to the new server now, too. That was the last of the stuff to go. Yay new server!

Note: See TracTickets for help on using tickets.