Ticket #346 (closed defect: invalid)

Opened 10 years ago

Last modified 10 years ago

flac not updated

Reported by: heini Owned by: ciaranm
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.24.5
Keywords: Cc:
Blocked By: Blocking:
Distribution:

Description

Hi,

when I do "paludis -ip everything" flac isn't listed for update, but when I want to (re-)install amarok, flac is listed for update from 1.1.2 to 1.1.4 (1.2.0 is also available, but masked):

These packages will be installed:

  • media-libs/flac-1.1.4 {:0} [U 1.1.2-r8] -3dnow -debug doc ogg sse
  • media-sound/amarok-1.4.6-r1 {:0} [R] arts -daap -debug -ifp -ipod kde mp4 -mtp musicbrainz -mysql -njb -noamazon opengl postgres python real -visualization -xinerama linguas: -af -ar -az -be -bg -bn -br -ca -cs -cy -da de -el -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hu -id -is -it -ja -km -ko -ku -lo -lt -mk -ms -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -rw -se -sk -sl -sq -sr -sr@Latn -ss -sv -ta -tg -th -tr -uk -uz -zh_CN -zh_TW

Total: 2 packages (1 upgrade, 1 rebuild)

PALUDIS_OPTIONS is set to "--dl-downgrade warning --dl-reinstall if-use-changed"

paludis version is 0.24.6 (not listed).

I've verified this on two (~x86) machines.

Attachments

paludis.log.bz2 Download (37.3 KB) - added by heini 10 years ago.

Change History

comment:1 Changed 10 years ago by ciaranm

Please try paludis -pi everything --log-level debug and attach the output.

Changed 10 years ago by heini

comment:2 Changed 10 years ago by heini

Add: This weekend amarok was amongst the packages to be updated with "paludis -i everything", but even this didn't update flac.

comment:3 Changed 10 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to invalid
  ... When adding installed package 'media-libs/libsndfile-1.0.17::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '~media-libs/flac-1.1.2':
  ... Taking installed package 'media-libs/flac-1.1.2-r8::installed' over 'media-libs/flac-1.1.2-r8::gentoo'

Your installed libsndfile prevents the upgrade.

comment:4 Changed 10 years ago by heini

Aaargh. It's always the same story. The ebuild of libsndfile has been changed without adding a "-rX" to the version to force a reinstall. Thus, the installed ebuild in /var/db/pkg depends on "~media-libs/flac-1.1.2", while the new one in the protage tree just depends on "media-libs/flac".

Thanks a lot for your effort.

Note: See TracTickets for help on using tickets.