Ticket #212 (closed defect: invalid)

Opened 10 years ago

Last modified 10 years ago

paludis has symlink problems

Reported by: yoshi314 Owned by: ciaranm
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.22.2
Keywords: Cc:
Blocked By: Blocking:
Distribution:

Description

recently i took qt-4.3.0-beta1 for a spin when it got ~x86 flag.

after a while a decided to go back to 4.2, because of certain UI layout bugs in some apps. because i forgot to quickpkg it beforehand, i installed it normally (via paludis of course).

the problem was - qt4-based apps didn't start. it appeared that symlinks to qt4 libs were unchanged since 4.3, and still pointed to 4.3 libraries, which were no longer there. so i had to fix them manually. everything started working normally after that.


second symlink problem.

  1. installed paludis 0.22.2 with portage useflag
  1. reinstalled paludis 0.22.2 without that flag.
  1. i was left with two bogus symlinks (pointing at each other) to non-existant .so file

paludis wouldn't start because it could not find the .so file that symlinks used to point at. i had to delete those symlinks and everything was fine again.

both problems entountered with 0.22.2

Change History

comment:1 Changed 10 years ago by ciaranm

Specifics!

comment:2 Changed 10 years ago by yoshi314

what info do you exactly need?

just noticed third occurence - unmerging openoffice-bin-2.2.0

ALL symlinks are left behind because of [!mtime] errors. i'm 100% sure i didn't modify/touch them in any way whatsoever.

on second thought, i just recently tarred my entire gentoo installation (tar xvjpf ) and unpacked it into different partition. i doubt it would cause modification time alterations, though. but then again it might.

qt-4.3 was installed after moving the system, however. so i think the real problem lies elsewhere.

in the meantime, i'll try to reproduce the paludis symlink problem again.

comment:3 Changed 10 years ago by yoshi314

  • Status changed from new to closed
  • Resolution set to invalid

edit: it appears that if i reinstall the package which was initially installed via portage, the symlinks problem gets resolved - they're removed on uninstall.

it still beats me what actually happened to them.

comment:4 Changed 10 years ago by ciaranm

tar doesn't preserve symlink mtimes.

Note: See TracTickets for help on using tickets.