Ticket #196 (closed defect: wontfix)

Opened 10 years ago

Last modified 10 years ago

adjutrix -w ~mips =sys-auth/pam_usb-0.4.0 gives AllMaskedError (Problems handling -arch in deptree)

Reported by: betelgeuse Owned by: ciaranm
Priority: Sometime Milestone:
Component: clients/adjutrix Version: 0.22.2
Keywords: Cc:
Blocked By: Blocking:
Distribution:

Description

betelgeuse@pena /usr/portage/sys-auth/pam_usb $ adjutrix -w ~mips =sys-auth/pam_usb-0.4.0

Unhandled exception:

  • In program /usr/bin/adjutrix --log-level silent --write-cache-dir /var/cache/paludis/metadata/ -w ~mips =sys-auth/pam_usb-0.4.0:
  • When performing what-needs-keywording action:
  • When adding PackageDepSpec? '=sys-auth/pam_usb-0.4.0':
  • When adding package 'sys-auth/pam_usb-0.4.0::gentoo':
  • When adding build dependencies as pre dependencies:
  • When adding PackageDepSpec? '>=sys-apps/hal-0.5.7.1-r3':
  • When adding package 'sys-apps/hal-0.5.7.1-r5::gentoo':
  • When adding build dependencies as pre dependencies:
  • When adding PackageDepSpec? '>=sys-apps/dmidecode-2.7':
  • Error searching for '>=sys-apps/dmidecode-2.7': no available versions (paludis::AllMaskedError?)

paludis 0.22.2

I think this is caused by either -mips in hal or dmidecode -*. Instead of giving the exception, adjutrix should use the Masks column to show that they are currently masked.

Change History

comment:1 Changed 10 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to wontfix

This is intentional. We don't override -keywords because it means the package has been explicitly marked as not available.

comment:2 Changed 10 years ago by betelgeuse

  • Status changed from closed to reopened
  • Resolution wontfix deleted

And -arch means the same thing as package.mask yet you put package.mask under the Masks column. Added dev-java/ant-core to package.mask and here is what I get:

betelgeuse@pena /usr/portage/profiles $ adjutrix -w x86 dev-util/netbeans:5.5
Package                       Version             Current Keywords  Masks
============================= =================== ================= =========
dev-java/sun-jaxws-bin        2.0-r1              ~x86
dev-java/sun-saaj-bin         1.3                 ~x86
dev-java/sun-jaxrpc-bin       1.1.3.01            ~x86
dev-java/sun-jaxb-bin         2.0-r2              ~x86
dev-java/sun-jwsdp-shared-bin 2.0-r1              ~x86
dev-java/sun-jaxp-bin         1.3.1.01            ~x86
dev-java/sun-sjsxp-bin        1.0                 ~x86
dev-java/sun-fastinfoset-bin  1.0.1               ~x86
dev-java/jsr250               1.0                 ~x86
dev-java/jsr181               0.7                 ~x86
dev-java/xerces               2.8.1               ~x86
dev-java/swing-layout         1.0.1-r1            ~x86
dev-java/jmi-interface        1.0-r3              ~x86
dev-java/jakarta-jstl         1.1.2-r1            ~x86
dev-java/prefuse              20060715_beta       ~x86
dev-java/glassfish-persistence1.0                 ~x86
dev-java/ant-core             1.6.5-r14           x86               R
dev-java/ant-core             1.7.0               ~x86              R
dev-util/netbeans             5.5-r5              ~x86

Please make the behavior consistent.

comment:3 Changed 10 years ago by ciaranm

  • Status changed from reopened to closed
  • Resolution set to wontfix

-keyword means "known not to be available on this arch". -* means "known only to be available on indicated archs". Thus, neither are suitable for overriding, since the packages are explicitly saying "we are not available on this arch".

Note: See TracTickets for help on using tickets.