Ticket #181 (closed defect: invalid)

Opened 8 years ago

Last modified 8 years ago

Unexpeced downgrade

Reported by: Farcaller Owned by: ciaranm
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.22.2
Keywords: Cc:
Blocked By: Blocking:
Distribution:

Description

# paludis -ip world
These packages will be installed:

* sys-libs/timezone-data-2007e {:0} [U 2007d] nls
* sys-apps/dbus-1.0.2-r2 {:0} [U 1.0.2-r1] X -debug -doc (-selinux)
* x11-apps/xinit-1.0.3-r2 {:0} [U 1.0.3-r1] -debug -minimal
* media-gfx/gimp-2.3.15 {:2} [U 2.3.14] -aalib alsa (-altivec) -debug -doc -gnome -gtkhtml jpeg -lcms mmx mng pdf png python smp sse svg tiff -wmf <world>
* x11-libs/qt-3.3.8-r1 {:3} [D 3.3.8-r2] cups -debug doc examples -firebird gif -immqt -immqt-bc -ipv6 mysql -nas -nis -odbc opengl -postgres sqlite -xinerama

Total: 5 packages (4 upgrades, 1 downgrade)
# emerge -uDNp world
Calculating world dependencies                  ... done!
[ebuild     U ] sys-libs/timezone-data-2007e [2007d] USE="nls" 341 kB
[ebuild     U ] sys-apps/dbus-1.0.2-r2 [1.0.2-r1] USE="X -debug -doc (-selinux)" 0 kB
[ebuild     U ] x11-apps/xinit-1.0.3-r2 [1.0.3-r1] USE="-debug -minimal" 0 kB
[ebuild     U ] media-gfx/gimp-2.3.15 [2.3.14] USE="alsa jpeg mmx mng pdf png python smp sse svg tiff -aalib (-altivec) -debug -doc -gnome -gtkhtml -lcms -wmf" 15,704 kB

Total: 4 packages (4 upgrades)

I really see no reason why paludis should downgrade qt.

Attachments

debug.bz2 Download (20.1 KB) - added by Farcaller 8 years ago.
paludis -pi world --log-level debug

Change History

Changed 8 years ago by Farcaller

paludis -pi world --log-level debug

comment:1 Changed 8 years ago by tommy

i read the debug output. there is a version parsing error that i think should be fixed. (not related to downgrade problem)

  ... Skipping entry '/usr/portage/media-video/mplayer/mplayer-1.0_rc2_pre20070321-r4.ebuild' for 'media-video/mplayer' in repository 'gentoo' due to exception 'Name '1.0_rc2_pre20070321-r4' is not a valid version spec: unexpected trailing text 're20070321-r4'' (paludis::BadVersionSpecError)'

comment:2 Changed 8 years ago by Farcaller

Regarding mplayer: #171

comment:3 Changed 8 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.