Ticket #173 (closed defect: invalid)

Opened 10 years ago

Last modified 10 years ago

Paludis's ruby support requires rubygems, but it is not a dependancy.

Reported by: eternaleye Owned by: rbrown
Priority: Sometime Milestone:
Component: repositories/e/ebuild Version: 0.20.1
Keywords: Cc:
Blocked By: Blocking:
Distribution:

Description

Emerging paludis fialed several times, complaining that it couldn't find ruby's ARCHDIR before I figured this out.

Suggested change: add a "ruby? ( dev-ruby/rubygems )" line to the depend portion of the ebuild.

Change History

comment:1 Changed 10 years ago by rbrown

  • Owner changed from ciaranm to rbrown

I suggest you actually post the error you received. Errors where packages "need" rubygems usually involves an out of date environment after uninstalling rubygems.

comment:2 Changed 10 years ago by eternaleye

I am not sure of the exact error, as it occurred while I was installing and I didn't think to log it. However, it occurred after I installed ruby and then immediately installed paludis, fetching up against an error during the ./config which I believe looked like "ERROR: cannot find $RUBY_ARCHDIR". I then emerged paludis with use -ruby, and tried to re-merge paludis using paludis, but hit the same error. I then ran eix -Cc dev-ruby , and looked for anything that might have anything to do with it. I came upon rubygems, which mentioned that it was a module system, so I installed it based on a gut feeling, and then paludis emerged with the ruby use flag. So, there is a rather high amount of guesswork to what I did, but I figured it might be something. This was 0.20.2, BTW.

comment:3 Changed 10 years ago by ciaranm

Pretty sure that this is down to a stray /etc/env.d/ file. If you install then uninstall gems its env.d file won't be removed because of CONFIG_PROTECT...

comment:4 Changed 10 years ago by rbrown

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.