Ticket #171 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

multiple suffixes in version

Reported by: Yaroslav Owned by: ciaranm
Priority: MajorRelease Milestone:
Component: clients/paludis Version: 0.20.1
Keywords: version suffix Cc:
Blocked By: Blocking:
Distribution:

Description

Some problem with new mplayer versioning scheme:

Building dependency list...paludis@1175122569: [WARNING] In program paludis -ip world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When adding PackageDepSpec 'virtual/baselayout':
  ... When loading VDB PROVIDEs map the slow way:
  ... When loading VDBRepository entries from '/var/db/pkg':
  ... When loading VDBRepository entries for 'media-video' from '/var/db/pkg':
  ... Ignoring VDB entry '/var/db/pkg/media-video/mplayer-1.0_rc2_pre20070321-r3' due to exception 'Name '1.0_rc2_pre20070321-r3' is not a valid version spec' (paludis::BadVersionSpecError)

Change History

comment:1 Changed 11 years ago by peper

  • Keywords version suffix added; mplayer problem removed
  • Summary changed from new mplayer versioning scheme makes problems to multiple suffixes in version

As far as I understood ciaran, support for such versions won't be implemented in paludis until agreed upon and documented.

gentoo  #166522

comment:2 Changed 11 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to invalid

Right. The mplayer suffixes are illegal according to the devmanual, the Portage docs and PMS, so Paludis won't support them. Either the tree or the docs need to be fixed.

Note: See TracTickets for help on using tickets.