Ticket #1259 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

python bindings fail to build with boost-1.52

Reported by: mgorny Owned by:
Priority: Sometime Milestone:
Component: bindings/python Version: 0.82.0
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

The issue existed for the last few releases. I'll attach the build log.

Relevant Gentoo bug:  https://bugs.gentoo.org/show_bug.cgi?id=423923

Attachments

20121203-115624.log.bz2 Download (22.6 KB) - added by mgorny 6 years ago.
The build log

Change History

Changed 6 years ago by mgorny

The build log

comment:1 follow-up: ↓ 2 Changed 6 years ago by ciaranm

Googling suggests -DBOOST_PYTHON_MAX_ARITY=20 for some sufficiently large value of 20 might fix it? (You may or may not need this when building boost too.)

comment:2 in reply to: ↑ 1 Changed 6 years ago by mgorny

Replying to ciaranm:

Googling suggests -DBOOST_PYTHON_MAX_ARITY=20 for some sufficiently large value of 20 might fix it? (You may or may not need this when building boost too.)

I've just tried 30 and it doesn't help. Just makes the error message list more arguments like:

/usr/include/boost/python/make_function.hpp:79:7: note:   mismatched types 'RT (ClassT::*)(T0, T1, T2, T3, T4, T5, T6, T7, T8, T9, T10, T11, T12, T13, T14, T15, T16, T17, T18, T19, T20, T21, T22, T23, T24, T25, T26, T27, T28, T29)const volatile' and 'boost::python::api::object'

comment:3 Changed 6 years ago by ciaranm

Hrm. I can't reproduce this with gcc 4.5. Wonder whether it's gcc version related.

comment:4 Changed 6 years ago by ciaranm

Can't reproduce it with gcc 4.6 either.

comment:5 Changed 6 years ago by mgorny

I'm running 4.7.2 here.

comment:6 Changed 6 years ago by dleverton

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed by 6bda8b8

Note: See TracTickets for help on using tickets.