Ticket #1118 (closed support-request: invalid)

Opened 7 years ago

Last modified 7 years ago

unmet required use constraints

Reported by: asliebe Owned by:
Priority: MinorRelease Milestone:
Component: clients/cave Version: 0.58.2
Keywords: unmet contraints Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

Whenever I try to install/update app-misc/mc cave fails with the following error:

Executing pretend actions: 1 of 1cave@1297542541: [WARNING util.system.boxless] In thread ID '2389':
  ... In program cave execute-resolution --preserve-world --world-specs app-misc/mc app-misc/mc:
  ... When executing chosen resolution:
  ... When pretending for '=app-misc/mc-4.7.5.1:0::gentoo':
  ... When running pretend for 'app-misc/mc-4.7.5.1:0::gentoo':
  ... When running an ebuild command on 'app-misc/mc-4.7.5.1:0::gentoo':
  ... I don't seem to be able to use sydbox
>>> Running ebuild phase bad_required_use as paludisbuild:paludisbuild...

 * The following required use constraints are unmet for app-misc/mc-4.7.5.1:
 *     ^^ ( ncurses slang )

>>> Completed ebuild phase bad_required_use

This happens although I've enabled all use flags in /etc/paludis/use.conf

n   app-misc/mc:0::gentoo 4.7.5.1 to ::installed
    "GNU Midnight Commander is a text based file manager"
    X edit gpm ncurses nls samba slang build_options: -optional_tests split strip -trace -preserve_work
    Reasons: target
    2.53 MBytes to download

Change History

comment:1 Changed 7 years ago by ciaranm

  • Status changed from new to closed
  • Type changed from defect to support-request
  • Resolution set to invalid

means "exactly one".

Note: See TracTickets for help on using tickets.