Ticket #1080 (closed ebuild-defect: fixed)

Opened 8 years ago

Last modified 8 years ago

resolver scores self-dependent unmet [use] deps too highly

Reported by: ojezu Owned by:
Priority: MinorRelease Milestone:
Component: clients/cave Version: 0.56.3
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

After repairing php-ext-source-r2.eclass so run dependency order is right in suhosin (according to bug #1078) , cave instead of building suhosin (and other php modules) across php5-2 only, requries php5-3 to be set.

$ cave resolve suhosin

I cannot proceed without being permitted to do the following:

n   dev-php5/suhosin:0::gentoo 0.9.32.1-r2 to ::installed
    "Suhosin is an advanced protection system for PHP installations."
    Need changes for: PHP_TARGETS: php5-3 No changes needed: PHP_TARGETS: php5-2 build_options: -optional_tests split strip -trace -preserve_work
    Reasons requiring changes: restarted because of dev-php5/suhosin Reasons: target, dev-php5/suhosin
    Cannot proceed without: being reconfigured


$ cave info suhosin

Package Manager Information:
    Package Name              paludis
    Package Version           0.56.3
    Build Date                2011-01-08T18:42:24+0100
    Built with CXX            x86_64-pc-linux-gnu-g++ 4.4.4
    Built with CXXFLAGS        -march=native -O2 -pipe -pedantic
    Built with LDFLAGS        -Wl,-O2

Environment Information:
    Format                    paludis
    Config dir                /etc/paludis
    Root                      /
    System Root               /
    World file                /var/db/pkg/world

Repository installed-virtuals:
    format                    installed_virtuals
    root                      /

Repository virtuals:
    format                    virtuals

Repository gentoo:
    format                    e
    location                  /usr/portage
    builddir                  /var/tmp/paludis
    cache                     /usr/portage/metadata/cache
    distdir                   /usr/portage/distfiles
    eapi_when_unknown         0
    eapi_when_unspecified     0
    eclassdirs                /usr/portage/eclass
    layout                    traditional
    names_cache               /usr/portage/.cache/names
    newsdir                   /usr/portage/metadata/news
    profile_eapi_when_unspecified 0
    profile_layout            traditional
    profiles                  /usr/portage/profiles/default/linux/amd64/10.0/no-multilib
    securitydir               /usr/portage/metadata/glsa
    setsdir                   /usr/portage/sets
    sync                      rsync://rsync.gentoo.org/gentoo-portage
    sync_options              
    use_manifest              use
    write_cache               /var/cache/paludis/metadata
    Package information
        app-admin/eselect-compiler (none)
        app-shells/bash       4.1_p7
        dev-java/java-config  (none)
        dev-lang/python       2.6.6-r1 3.1.2-r4
        dev-util/ccache       (none)
        dev-util/cmake        2.8.1-r2
        dev-util/confcache    (none)
        sys-apps/baselayout   1.12.14-r1
        sys-apps/openrc       (none)
        sys-apps/sandbox      2.4
        sys-devel/autoconf    2.65-r1
        sys-devel/automake    1.10.3 1.11.1
        sys-devel/binutils    2.20.1-r1
        sys-devel/gcc         4.3.4 4.4.4-r2
        sys-devel/gcc-config  1.4.1
        sys-devel/libtool     2.2.10
        sys-devel/make        3.81-r2
        virtual/os-headers    2.6.30-r1 (for sys-kernel/linux-headers::installed)

Repository installed:
    format                    vdb
    location                  /var/db/pkg
    builddir                  /var/tmp/paludis
    eapi_when_unknown         0
    names_cache               /var/db/pkg/.cache/names
    provides_cache            /var/db/pkg/.cache/provides
    root                      /

Extra Information for dev-php5/suhosin-0.9.32.1-r2:0::gentoo:
        >>> Running ebuild phase killold as paludisbuild:paludisbuild...
        >>> Starting builtin_killold
        >>> Done builtin_killold
        >>> Completed ebuild phase killold
        >>> Running ebuild phases initmisc infovars as paludisbuild:paludisbuild...
        >>> Starting builtin_initmisc
        >>> Done builtin_initmisc
        >>> Starting builtin_infovars
        ACCEPT_KEYWORDS=amd64
        CBUILD=x86_64-pc-linux-gnu
        CFLAGS=-march=native -O2 -pipe
        CHOST=x86_64-pc-linux-gnu
        CONFIG_PROTECT= 
        CONFIG_PROTECT_MASK= 
        CPPFLAGS=
        CTARGET=
        CXXFLAGS=-march=native -O2 -pipe
        DISTDIR=/usr/portage/distfiles
        FEATURES=
        FFLAGS=
        GENTOO_MIRRORS=
        INSTALL_MASK=
        LANG=
        LC_ALL=C
        LDFLAGS=-Wl,-O2
        LINGUAS=en en_GB
        MAKEOPTS=-j2
        PORTAGE_COMPRESS=
        PORTAGE_COMPRESS_FLAGS=
        PORTAGE_CONFIGROOT=
        PORTAGE_RSYNC_EXTRA_OPTS=
        PORTAGE_RSYNC_OPTS=
        PORTAGE_TMPDIR=/var/tmp/paludis
        PORTDIR=/usr/portage
        PORTDIR_OVERLAY=
        SYNC=
        USE=amd64 alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2_modules_actions apache2_modules_alias apache2_modules_auth_basic apache2_modules_authn_alias apache2_modules_authn_anon apache2_modules_authn_dbm apache2_modules_authn_default apache2_modules_authn_file apache2_modules_authz_dbm apache2_modules_authz_default apache2_modules_authz_groupfile apache2_modules_authz_host apache2_modules_authz_owner apache2_modules_authz_user apache2_modules_autoindex apache2_modules_cache apache2_modules_cgi apache2_modules_cgid apache2_modules_dav apache2_modules_dav_fs apache2_modules_dav_lock apache2_modules_deflate apache2_modules_dir apache2_modules_disk_cache apache2_modules_env apache2_modules_expires apache2_modules_ext_filter apache2_modules_file_cache apache2_modules_filter apache2_modules_headers apache2_modules_include apache2_modules_info apache2_modules_log_config apache2_modules_logio apache2_modules_mem_cache apache2_modules_mime apache2_modules_mime_magic apache2_modules_negotiation apache2_modules_rewrite apache2_modules_setenvif apache2_modules_speling apache2_modules_status apache2_modules_unique_id apache2_modules_userdir apache2_modules_usertrack apache2_modules_vhost_alias collectd_plugins_df collectd_plugins_interface collectd_plugins_irq collectd_plugins_load collectd_plugins_memory collectd_plugins_rrdtool collectd_plugins_swap collectd_plugins_syslog elibc_glibc gpsd_protocols_aivdm gpsd_protocols_ashtech gpsd_protocols_earthmate gpsd_protocols_evermore gpsd_protocols_fv18 gpsd_protocols_garmin gpsd_protocols_garmintxt gpsd_protocols_gpsclock gpsd_protocols_itrax gpsd_protocols_mtk3301 gpsd_protocols_navcom gpsd_protocols_nmea gpsd_protocols_ntrip gpsd_protocols_oceanserver gpsd_protocols_oldstyle gpsd_protocols_oncore gpsd_protocols_rtcm104v2 gpsd_protocols_rtcm104v3 gpsd_protocols_sirf gpsd_protocols_superstar2 gpsd_protocols_timing gpsd_protocols_tnt gpsd_protocols_tripmate gpsd_protocols_tsip gpsd_protocols_ubx input_devices_keyboard kernel_linux lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text linguas_en linguas_en_GB php_targets_php5-2 ruby_targets_ruby18 sane_backends_hp sane_backends_hp4200 sane_backends_net sane_backends_plustek userland_GNU video_cards_vesa xtables_addons_account xtables_addons_chaos xtables_addons_condition xtables_addons_delude xtables_addons_dhcpmac xtables_addons_fuzzy xtables_addons_geoip xtables_addons_iface xtables_addons_ipmark xtables_addons_ipp2p xtables_addons_ipset xtables_addons_ipv4options xtables_addons_length2 xtables_addons_logmark xtables_addons_lscan xtables_addons_pknock xtables_addons_psd xtables_addons_quota2 xtables_addons_rawnat xtables_addons_steal xtables_addons_sysrq xtables_addons_tarpit xtables_addons_tee amd64 
        >>> Done builtin_infovars
        >>> Completed ebuild phases initmisc infovars
        >>> Running ebuild phase tidyup as paludisbuild:paludisbuild...
        >>> Starting builtin_tidyup
        rm -fr /var/tmp/paludis/dev-php5-suhosin-0.9.32.1-r2-info
        >>> Done builtin_tidyup
        >>> Completed ebuild phase tidyup

cave show suhosin -c

* dev-php5/suhosin
    ::gentoo                  0.9.31 (0.9.32.1)K (0.9.32.1-r1)K 0.9.32.1-r2* {:0}
    dev-php5/suhosin-0.9.32.1-r2:0::gentoo
        Description           Suhosin is an advanced protection system for PHP installations.
        Homepage              http://www.suhosin.org/
        Use flags             
            php_targets       
                php5-2        Build against PHP 5.2
                -php5-3       Build against PHP 5.3
            Build Options     
                -optional_tests Run tests considered by the package to be optional
                split         Split debugging information out from binaries and libraries before installation
                strip         Strip binaries and libraries before installation
                -trace        Trace actions executed by the package (very noisy, for debugging broken builds only)
                -preserve_work Do not remove build directories, and do not modify the image when merging
        Build dependencies    
                              dev-lang/php[unicode]
                              || (
                                  =sys-devel/automake-1.11*
                              )
                              >=sys-devel/autoconf-2.61
                              >=sys-devel/libtool-2.2.6b
                              >=sys-devel/m4-1.4.3
                              >=sys-devel/libtool-1.5.18
        Post dependencies     
        Provided packages     
        Run dependencies      
                              dev-lang/php[unicode]
                              || (
                                  =dev-php5/suhosin-0.9.32.1-r2[php_targets_php5-3]
                                  =dev-php5/suhosin-0.9.32.1-r2[php_targets_php5-2]
                              )
                              php_targets_php5-3? (
                                  dev-lang/php:5.3
                              )
                              php_targets_php5-2? (
                                  dev-lang/php:5.2
                              )
        Source URI            
                              http://download.suhosin.org/suhosin-0.9.32.1.tar.gz

Although dependecy order is RIGHT cave still refuses to perform some sane operations, as some users may have very good reasons to use PHP_TARGETS for what it was intended for.

Change History

comment:1 Changed 8 years ago by ciaranm

  • Status changed from new to closed
  • Type changed from defect to ebuild-defect
  • Summary changed from Cave does not install suhosin with PHP_TARGETS: php5-2 -php5-3 after repairing eclass. to resolver scores self-dependent unmet [use] deps too highly
  • Resolution set to fixed
  • Milestone cave Basic Functionality deleted

Note: See TracTickets for help on using tickets.