Ticket #1051 (closed defect: fixed)

Opened 8 years ago

Last modified 6 years ago

-mb hates accounts

Reported by: filko_ Owned by:
Priority: Sometime Milestone:
Component: clients/cave Version: scm
Keywords: Cc:
Blocked By: Blocking:
Distribution: Exherbo

Description

(chroot) tre a # cave resolve test/a -b '*/*'
Done: 25 steps               

These are the actions I will take, in order:

n   group/zombie::accounts 0 to ::installed-accounts
    "zombie"
    Reasons: user/zombie
n   user/zombie::accounts 0 to ::installed-accounts
    "i eat brainz"
    Reasons: test/a
n   test/a:0::filko 1 to ::karambol-bin
    build_options: -recommended_tests split strip jobs=12 -trace -preserve_work
    Reasons: target (to be like test/a:0::(install_to_slash))
n   test/a:0::filko 1 to ::installed via binary created in karambol-bin
    build_options: -recommended_tests split strip jobs=12 -trace -preserve_work
    Reasons: target

Total: 3 new installs, 1 binaries

Build Options:
    jobs:                          Set with an integer value to specify how many jobs the package's build system should use, where supported
    preserve_work:                 Do not remove build directories, and do not modify the image when merging
    recommended_tests:             Run tests considered by the package to be recommended
    split:                         Split debugging information out from binaries and libraries before installation
    strip:                         Strip binaries and libraries before installation
    trace:                         Trace actions executed by the package (very noisy, for debugging broken builds only)

Executing pretend actions: 4 of 4

 * No unread news items found
(chroot) tre a # cave resolve test/a -mb
Done: 10 steps              

These are the actions I will take, in order:

n   test/a:0::filko 1 to ::karambol-bin
    build_options: -recommended_tests split strip jobs=12 -trace -preserve_work
    Reasons: target

Total: 1 binaries

Build Options:
    jobs:                          Set with an integer value to specify how many jobs the package's build system should use, where supported
    preserve_work:                 Do not remove build directories, and do not modify the image when merging
    recommended_tests:             Run tests considered by the package to be recommended
    split:                         Split debugging information out from binaries and libraries before installation
    strip:                         Strip binaries and libraries before installation
    trace:                         Trace actions executed by the package (very noisy, for debugging broken builds only)

I encountered the following errors:

!   user/zombie
    Reasons: test/a
    Unsuitable candidates:
      * Found no packages for resolvent user/zombie:(no slot)::(install_to_slash)

Change History

comment:1 Changed 8 years ago by ciaranm

Hrm, it's trying to find a user/zombie:(no slot)::(install_to_slash), not a create_binary. Could you do a -X zombie and check that it's just trying to put the user on / and not also make a binary for it?

comment:2 Changed 8 years ago by filko_

Explaining requested decisions:

For user/zombie:(no slot)::(install_to_slash):
    The following constraints were in action:
      * user/zombie, use existing if possible, creating a binary
        Because of user/zombie from test/a-1:0::filko, key 'Dependencies', labelled 'build, run'
    No decision could be made

comment:3 Changed 8 years ago by ciaranm

The problem is with MakeOriginFilteredGeneratorHelper. If binaries are being made as the goal, it stops origins that can't be made into binaries from being selected.

comment:4 Changed 8 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to fixed

Think I've fixed it now.

comment:5 Changed 8 years ago by filko_

It seems to be back, but this times it only argues if the account is already installed and also bitches about repositories that are configured and in world. As above, -b is fine.

(karambol) tre ~ # cave resolve test/a -mb -X user/zombie
Done: 640 steps               

These are the actions I will take, in order:

r   test/a:0::filko 1 to ::karambol-bin replacing 1
    build_options: -recommended_tests split strip jobs=12 -trace -preserve_work
    Reasons: target

Total: 1 binaries

I encountered the following errors:

!   user/zombie
    Reasons: test/a, test/a (to be like user/zombie:(no slot)::(install_to_slash))
    Unsuitable candidates:
      * user/zombie-0::accounts
        Masked by already installed (Manipulating accounts that are already present is not supported)
!   group/zombie
    Reasons: user/zombie, user/zombie (to be like group/zombie:(no slot)::(install_to_slash))
    Unsuitable candidates:
      * group/zombie-0::accounts
        Masked by already installed (Manipulating accounts that are already present is not supported)

Explaining requested decisions:

For user/zombie:(no slot)::(install_to_slash):
    The following constraints were in action:
      * user/zombie, use existing if possible, creating a binary
        Because of user/zombie from test/a-1:0::filko, key 'Dependencies', labelled 'build, run'
      * user/zombie, use existing if possible, installing to /
        Because of user/zombie from test/a-1:0::filko, key 'Dependencies', labelled 'build, run' (to be like user/zombie:(no slot)::(create_binary))
    The decision made was:
        Use existing ID user/zombie-0::installed-accounts
For user/zombie:(no slot)::(create_binary):
    The following constraints were in action:
      * user/zombie, use existing if possible, creating a binary
        Because of user/zombie from test/a-1:0::filko, key 'Dependencies', labelled 'build, run'
      * user/zombie, use existing if possible, creating a binary
        Because of user/zombie from test/a-1:0::filko, key 'Dependencies', labelled 'build, run' (to be like user/zombie:(no slot)::(install_to_slash))
    No decision could be made

comment:6 Changed 8 years ago by filko_

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:7 Changed 6 years ago by ciaranm

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.