Ticket #1015 (new enhancement)

Opened 7 years ago

Last modified 7 years ago

cave resolve error for blockers could be improved

Reported by: pioto Owned by:
Priority: Sometime Milestone:
Component: clients/cave Version: scm
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

I encountered the following errors:

!   media-fonts/gnu-gs-fonts-std
    Reasons: !media-fonts/gnu-gs-fonts-std from media-fonts/urw-fonts
    Unsuitable candidates:
      * media-fonts/gnu-gs-fonts-std-6.0:0::gentoo
        Did not meet !media-fonts/gnu-gs-fonts-std, use existing if possible, installing to / from !media-fonts/gnu-gs-fonts-std from media-fonts/urw-fonts
      * media-fonts/gnu-gs-fonts-std-8.11:0::gentoo
        Did not meet !media-fonts/gnu-gs-fonts-std, use existing if possible, installing to / from !media-fonts/gnu-gs-fonts-std from media-fonts/urw-fonts

It'd be nice to say something like "blocked by media-fonts/urw-fonts", and maybe explain why that's being pulled in. And suggest using -U as a possible workaround.

Change History

comment:1 Changed 7 years ago by ciaranm

Don't think we can, without blocker annotations. The message on Exherbo should be better...

comment:2 in reply to: ↑ description Changed 7 years ago by dleverton

Replying to pioto:

And suggest using -U as a possible workaround.

See also #920

Note: See TracTickets for help on using tickets.