Ticket #1013 (closed defect: wontfix)

Opened 9 years ago

Last modified 9 years ago

paludis -u --with-dependencies: quite misleading

Reported by: fkater Owned by:
Priority: Sometime Milestone:
Component: clients/paludis Version: 0.54.4
Keywords: Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

If 'paludis -u a_packet' stops because a_packet is still required, it seems to list only the top most dependent packets which need it.

In my case: paludis -pu urw-fonts listed only ghostscript-gpl to be uninstalled as well. Then either --with-dependencies or unsafe-uninstall is recommended.

However adding --with-dependencies then started uninstalling about 60 packets (not only the two intended ones).

Change History

comment:1 Changed 9 years ago by ciaranm

  • Status changed from new to closed
  • Resolution set to wontfix

Showing the full list straight away makes the output excessively hard to read. If you want to use --with-dependencies, add it and redo the pretend.

Having said that, cave does this a bit differently, and makes you explicitly state which things you do and do not want to remove, so it's harder to screw up if you misuse it.

Note: See TracTickets for help on using tickets.