Ticket #1008 (closed support-request: invalid)

Opened 7 years ago

Last modified 7 years ago

cave-resolve useflag rdepend problem

Reported by: Pandor Owned by:
Priority: MajorRelease Milestone: cave Basic Functionality
Component: clients/cave Version: 0.54.3
Keywords: rdepend cave-resolve Cc:
Blocked By: Blocking:
Distribution: Gentoo

Description

virtual/httpd-php-5.3 depends on:

RDEPEND="
( =dev-lang/php-5.3*[apache2]

=dev-lang/php-5.3*[cgi] =dev-lang/php-5.3*[fpm] )

I have "-apache2" in use.conf, and "dev-lang/php cgi" in use.conf.d/php.conf.

'paludis -i installed-packages' resolves this just fine. 'cave resolve installed-packages' wants to build php with apache2 useflag.

Any reason for this? I have no need for apache, as I have lighttpd installed.

paludis output:  http://pastebin.com/gwh6aC2C cave output:  http://pastebin.com/T6zi885Q

Change History

comment:1 Changed 7 years ago by Pandor

That's:

RDEPEND="|| ( =dev-lang/php-5.3*[apache2]
			  =dev-lang/php-5.3*[cgi]
			  =dev-lang/php-5.3*[fpm] )"

comment:2 Changed 7 years ago by ciaranm

Could you add '-X php' to your resolve command and provide the output please? (Not in a pastebin, since they expire.)

comment:3 Changed 7 years ago by ciaranm

  • Status changed from new to closed
  • Type changed from defect to support-request
  • Resolution set to invalid

This is caused by you still having virtual/httpd-php:5.2 installed.

Note: See TracTickets for help on using tickets.